interpolatePointAndTangent MethodStatic

Return a ray with ray.origin interpolated between pt1 and pt2 at the given fraction and ray.direction set to the vector from pt1 to pt2 multiplied by the given scale factor.

interpolatePointAndTangent(pt1: Readonly<WritableXYAndZ>, fraction: number, pt2: Readonly<WritableXYAndZ>, tangentScale: number, result?: Ray3d): Ray3d

Parameter Type Description
pt1 Readonly<WritableXYAndZ> start point of interpolation.
fraction number fractional position between points.
pt2 Readonly<WritableXYAndZ> endpoint of interpolation.
tangentScale number scale factor to apply to the startToEnd vector.
result Ray3d optional receiver.

Returns - Ray3d

Defined in

Last Updated: 20 June, 2023