closestApproachRay3dRay3d MethodStatic
Determine if two rays intersect, are fully overlapped, parallel but no coincident, or skew
- Return a CurveLocationDetailPair which
- contains fraction and point on each ray.
- has (in the CurveLocationDetailPair structure, as member approachType) annotation indicating one of these relationships
- CurveCurveApproachType.Intersection -- the rays have a simple intersection, at fractions indicated in detailA and detailB
- CurveCurveApproachType.PerpendicularChord -- there is pair of where the rays have closest approach. The rays are skew in space.
- CurveCurveApproachType.CoincidentGeometry -- the rays are the same unbounded line in space. The fractions and points are a representative single common point.
- CurveCurveApproachType.Parallel -- the rays are parallel (and not coincident). The two points are at the minimum distance
closestApproachRay3dRay3d(rayA: Ray3d, rayB: Ray3d): CurveLocationDetailPair
Parameter | Type | Description |
---|---|---|
rayA | Ray3d | |
rayB | Ray3d |
Returns - CurveLocationDetailPair
Defined in
- geometry3d/Ray3d.ts Line 315
Last Updated: 20 June, 2023