compressShortEdges MethodStatic
Return a simplified subset of given points, omitting points if very close to their neighbors.
- This is a local search, with a single pass over the data.
compressShortEdges(source: Point3d[], maxEdgeLength: number): Point3d[]
Parameter | Type | Description |
---|---|---|
source | Point3d[] | input points |
maxEdgeLength | number |
Returns - Point3d[]
Defined in
- geometry3d/PolylineOps.ts Line 48
Last Updated: 20 June, 2023