PointStreamXYZXYZHandlerBase Class
Base class for handling points in pairs.
- Callers implement handleXYZXYZ to receive point pairs.
- Callers may implement startChain and endChain.
- Beware that if startChain is implemented it must call super.startChain () to reset internal x0, y0,z0 to undefined.
- If that is not done, a point pair will appear from the end of previous chain to start of new chain.
- This (intermediate base) class does NOT override startChain
Extends
-
Methods
Name | Description | |
---|---|---|
constructor(): PointStreamXYZXYZHandlerBase | ||
handleXYZ(x: number, y: number, z: number): void | ||
handleXYZXYZ(_x0: number, _y0: number, _z0: number, _x1: number, _y1: number, _z1: number): void | Handler function called successively for each point0, point1 pair. | |
startChain(_chainData: MultiLineStringDataVariant, _isLeaf: boolean): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
endChain(_chainData: MultiLineStringDataVariant, _isLeaf: boolean): void |
Defined in
- geometry3d/PointStreaming.ts Line 39
Last Updated: 20 June, 2023