factorOrthogonalScaleOrthogonal Method
Factor this matrix M as a product M = V * D * U where V and U are orthogonal, and D is diagonal (scale matrix).
factorOrthogonalScaleOrthogonal(matrixV: Matrix3d, scale: Point3d, matrixU: Matrix3d): boolean
Parameter | Type | Description |
---|---|---|
matrixV | Matrix3d | left orthogonal factor (allocate by caller, computed here) |
scale | Point3d | diagonal entries of D (allocate by caller, computed here) |
matrixU | Matrix3d | right orthogonal factor (allocate by caller, computed here) |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 1294
Last Updated: 20 June, 2023