createFrameWithCCWPolygon MethodStatic
try to create a frame whose xy plane is through points, with the points appearing CCW in the local frame.
- if 3 or more distinct points are present, the x axis is from the first point to the most distance, and y direction is toward the point most distant from that line.
createFrameWithCCWPolygon(points: Point3d[]): undefined | Transform
Parameter | Type | Description |
---|---|---|
points | Point3d[] | array of points |
Returns - undefined | Transform
Defined in
- geometry3d/FrameBuilder.ts Line 295
Last Updated: 20 June, 2023