radiansToUnitNormalRay MethodStatic
- if ellipsoid is given, return its surface point and unit normal as a Ray3d.
- if not given, return surface point and unit normal for unit sphere.
radiansToUnitNormalRay(ellipsoid: undefined | Ellipsoid, thetaRadians: number, phiRadians: number, result?: Ray3d): undefined | Ray3d
Parameter | Type | Description |
---|---|---|
ellipsoid | undefined | Ellipsoid | |
thetaRadians | number | |
phiRadians | number | |
result | Ray3d |
Returns - undefined | Ray3d
Defined in
- geometry3d/Ellipsoid.ts Line 661
Last Updated: 20 June, 2023