createCenterMatrixRadii MethodStatic
Create a transform with given center and directions, applying the radii as multipliers for the respective columns of the axes.
createCenterMatrixRadii(center: Point3d, axes: undefined | Matrix3d, radiusX: number, radiusY: number, radiusZ: number): Ellipsoid
Parameter | Type | Description |
---|---|---|
center | Point3d | center of ellipsoid |
axes | undefined | Matrix3d | x,y,z directions are columns of this matrix |
radiusX | number | multiplier to be applied to the x direction |
radiusY | number | multiplier to be applied to the y direction |
radiusZ | number | multiplier to be applied to the z direction |
Returns - Ellipsoid
Defined in
- geometry3d/Ellipsoid.ts Line 181
Last Updated: 20 June, 2023