polygonClip Method
Clip a polygon to the planes of the clip plane set.
- For a convex input polygon, the output is another convex polygon.
- For a non-convex input, the output may have double-back edges along plane intersections. This is still a valid clip in a parity sense.
- The containingPlane parameter allows callers within ConvexClipPlane set to bypass planes known to contain the polygon
polygonClip(input: Point3d[] | GrowableXYZArray, output: GrowableXYZArray, work: GrowableXYZArray, planeToSkip?: ClipPlane): void
Parameter | Type | Description |
---|---|---|
input | Point3d[] | GrowableXYZArray | input polygon, usually convex. |
output | GrowableXYZArray | output polygon |
work | GrowableXYZArray | work array. |
planeToSkip | ClipPlane |
Returns - void
Defined in
- clipping/ConvexClipPlaneSet.ts Line 599
Last Updated: 20 June, 2023