computePlanePlanePlaneIntersections Method
Compute intersections among all combinations of 3 planes in the convex set.
- optionally throw out points that are not in the set.
- optionally push the points in the caller-supplied point array.
- optionally extend a caller supplied range.
- In the common case where the convex set is (a) a slab or (b) a view frustum, there will be 8 points and the range is the range of the convex set.
- If the convex set is unbounded, the range only contains the range of the accepted (corner) points, and the range is not a representative of the "range of all points in the set" .
computePlanePlanePlaneIntersections(points: undefined | Point3d[], rangeToExtend: undefined | Range3d, transform?: Transform, testContainment: boolean = true): number
Parameter | Type | Description |
---|---|---|
points | undefined | Point3d[] | (optional) array to which computed points are to be added. |
rangeToExtend | undefined | Range3d | |
transform | Transform | (optional) transform to apply to the points. |
testContainment | boolean | if true, test each point to see if it is within the convex set. (Send false if confident that the convex set is rectilinear set such as a slab. Send true if chiseled corners are possible) |
Returns - number
number of points.
Defined in
- clipping/ConvexClipPlaneSet.ts Line 677
Last Updated: 20 June, 2023