extractBoundaryLoops Method
A simple way of packaging this ClipVector's ClipShape points into a multidimensional array, while also taking into account each ClipPrimitive's individual transforms.
ClipPrimitives OTHER THAN ClipShape are ignored.
Information out:
- All of the loop points are stored in the multidimensional Point3d array given (will return unchanged upon failure)
- If given a transform, will be set from the transformFromClip of the first ClipPrimitive
- The ClipMask of the final ClipPrimitive is stored in the returned array at index 0
- The last valid zLow found is stored in the returned array at index 1
- The last valid zHigh found is stored in the returned array at index 2
extractBoundaryLoops(loopPoints: Point3d[][], transform?: Transform): number[]
Parameter | Type | Description |
---|---|---|
loopPoints | Point3d[][] | |
transform | Transform |
Returns - number[]
Defined in
- clipping/ClipVector.ts Line 236
Last Updated: 20 June, 2023