classifyRangeContainment Method
Determines whether a 3D range lies inside or outside this set of ClipShapes. If any set is defined by masking planes, checks the mask planes only, provided that ignoreMasks is false. Otherwise, checks the clip planes member.
classifyRangeContainment(range: Range3d, ignoreMasks: boolean): ClipPlaneContainment
Parameter | Type | Description |
---|---|---|
range | Range3d | |
ignoreMasks | boolean |
Returns - ClipPlaneContainment
Defined in
- clipping/ClipVector.ts Line 355
Last Updated: 20 June, 2023