clipSegmentBelowPlanesXY MethodStatic
Clip an interval of a line segment to an array of planes
- plane normals assumed OUTWARD
- planeAltitude is typically a tolerance a tolerance distance.
- positive altitude makes tha plane move in the direction of the unit normal.
clipSegmentBelowPlanesXY(planes: Plane3dByOriginAndUnitNormal[], segment0: Readonly<WritableXAndY>, segment1: Readonly<WritableXAndY>, interval: Range1d, signedAltitude: number = 1.0e-14): void
Parameter | Type | Description |
---|---|---|
planes | Plane3dByOriginAndUnitNormal[] | array of planes |
segment0 | Readonly<WritableXAndY> | start of segment |
segment1 | Readonly<WritableXAndY> | end of segment |
interval | Range1d | Pre-initialized interval of live part of segment |
signedAltitude | number |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 682
Last Updated: 20 June, 2023