clipPolygonToClipShape MethodStatic
Clip a polygon down to regions defined by each shape of a ClipShape.
clipPolygonToClipShape(polygon: Point3d[], clipShape: ClipPrimitive): Point3d[][]
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | |
clipShape | ClipPrimitive |
Returns - Point3d[][]
An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Defined in
- clipping/ClipUtils.ts Line 196
Last Updated: 20 June, 2023