clipPolygonToClipShapeReturnGrowableXYZArrays MethodStatic
Clip a polygon down to regions defined by each shape of a ClipShape.
clipPolygonToClipShapeReturnGrowableXYZArrays(polygon: Point3d[], clipShape: ClipPrimitive): GrowableXYZArray[]
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | |
clipShape | ClipPrimitive |
Returns - GrowableXYZArray[]
An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Defined in
- clipping/ClipUtils.ts Line 208
Last Updated: 20 June, 2023