createNormalAndPoint MethodStatic
Create a ClipPlane
- "normal" is the inward normal of the plane. (It is internally normalized)
- "point" is any point of the plane.
- The stored distance for the plane is the dot product of the point with the normal (i.e. treat the point's xyz as a vector from the origin.)
createNormalAndPoint(normal: Vector3d, point: Point3d, invisible: boolean = false, interior: boolean = false, result?: ClipPlane): undefined | ClipPlane
Parameter | Type | Description |
---|---|---|
normal | Vector3d | |
point | Point3d | |
invisible | boolean | |
interior | boolean | |
result | ClipPlane |
Returns - undefined | ClipPlane
Defined in
- clipping/ClipPlane.ts Line 134
Last Updated: 20 June, 2023