getPolePoint3d MethodAbstract
Return a specified pole as a Point3d
- BSplineCurve3d returns its simple xyz
- BSplineCurve3dH attempts to normalize its (wx,wy,wz,w) back to (x,y,z), and returns undefined if weight is zero.
getPolePoint3d(poleIndex: number, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
poleIndex | number | |
result | Point3d | optional result |
Returns - undefined | Point3d
Defined in
- bspline/BSplineCurve.ts Line 204
Last Updated: 20 June, 2023