closestPoint Method
Search for the curve point that is closest to the spacePoint.
- If the space point is exactly on the curve, this is the reverse of fractionToPoint.
- Since CurvePrimitive should always have start and end available as candidate points, this method should always succeed
closestPoint(spacePoint: Point3d, _extend: boolean): undefined | CurveLocationDetail
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space |
_extend | boolean | ignored. A BSplineCurve3dBase cannot be extended. |
Returns - undefined | CurveLocationDetail
Returns a CurveLocationDetail structure that holds the details of the close point.
Defined in
- bspline/BSplineCurve.ts Line 221
Last Updated: 20 June, 2023