appendPlaneIntersectionPoints Method
Implement CurvePrimitive.appendPlaneIntersections
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | A plane (e.g. specific type Plane3dByOriginAndUnitNormal or Point4d) |
result | CurveLocationDetail[] | growing array of plane intersections |
Returns - number
number of intersections appended to the array.
Defined in
- bspline/BSplineCurve.ts Line 294
Last Updated: 20 June, 2023