getPoint3dAtCheckedPointIndex Method
Access by index, returning strongly typed Point3d
- This returns the xyz value but NOT reference to the point in the "carried" array.
getPoint3dAtCheckedPointIndex(index: number, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
index | number | index of point within the array |
result | Point3d | caller-allocated destination |
Returns - undefined | Point3d
undefined if the index is out of bounds
Defined in
Last Updated: 20 June, 2023