IndexedXYZCollectionInterval Class
Reference to an interval of the indices of an IndexedXYZCollection.
Extends
Methods
Name | Description | |
---|---|---|
constructor(points: IndexedXYZCollection, base: number, limit: number): IndexedXYZCollectionInterval Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
advanceBegin(): boolean | IndexedCollectionInterval<IndexedXYZCollection> | Add one to this.begin. |
advanceEnd(): boolean | IndexedCollectionInterval<IndexedXYZCollection> | advance this.end (but do not go beyond this.points.length) return true if the interval is still live. |
advanceToHead(other: IndexedCollectionInterval<IndexedXYZCollection>): boolean | IndexedCollectionInterval<IndexedXYZCollection> | Advance this.begin to (other.begin), i.e. |
advanceToTail(other: IndexedCollectionInterval<IndexedXYZCollection>): boolean | IndexedCollectionInterval<IndexedXYZCollection> | Advance this.begin to (other.end-1), i.e. |
localIndexToParentIndex(localIndex: number): undefined | number | IndexedCollectionInterval<IndexedXYZCollection> | Return (if possible) the parent index corresponding to localIndex |
restrictEnd(): void | IndexedCollectionInterval<IndexedXYZCollection> | restrict this.end to this.points.length |
setFrom(other: IndexedCollectionInterval<IndexedXYZCollection>, base?: number, limit?: number): void | IndexedCollectionInterval<IndexedXYZCollection> | Set this interval from another, with conditional replacements: |
createBeginEnd<T extends CollectionWithLength>(points: T, begin: number, end: number): IndexedCollectionInterval<T> Static | IndexedCollectionInterval<IndexedXYZCollection> | Create an interval which matches a collection from start <= i < end . |
createBeginLength<T extends CollectionWithLength>(points: T, begin: number, length: number): IndexedCollectionInterval<T> Static | IndexedCollectionInterval<IndexedXYZCollection> | Create an interval which matches a collection from start <= i < end . |
createComplete<T extends CollectionWithLength>(points: T): IndexedCollectionInterval<T> Static | IndexedCollectionInterval<IndexedXYZCollection> | Create an interval which matches a complete indexed collection. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
begin | number | IndexedCollectionInterval<IndexedXYZCollection> | lower limit of index range |
end | number | IndexedCollectionInterval<IndexedXYZCollection> | upper limit (beyond) index range. |
isNonEmpty Accessor ReadOnly | boolean | IndexedCollectionInterval<IndexedXYZCollection> | Return true if length is 1 or more |
isSingleton Accessor ReadOnly | boolean | IndexedCollectionInterval<IndexedXYZCollection> | Return true if the length is exactly 1 |
isValidSubset Accessor ReadOnly | boolean | IndexedCollectionInterval<IndexedXYZCollection> | Return true if * the interval is empty (the empty set is a subset of all sets!) * all indices in its range are valid. |
length Accessor ReadOnly | number | IndexedCollectionInterval<IndexedXYZCollection> | Return the number of steps possible with current begin and end |
points | IndexedXYZCollection | IndexedCollectionInterval<IndexedXYZCollection> | Any collection that has a .length member or property |
Defined in
Last Updated: 20 June, 2023