linearCombination Method
Compute the linear combination s of the indexed p_i and given scales s_i.
linearCombination(scales: number[], result?: Point3d | Vector3d): XYZ
Parameter | Type | Description |
---|---|---|
scales | number[] | array of scales. For best results, scales should have same length as the instance. |
result | Point3d | Vector3d | optional pre-allocated object to fill and return |
Returns - XYZ
s = sum(p_i * s_i), where i ranges from 0 to min(this.length, scales.length).
Defined in
- geometry3d/IndexedXYZCollection.ts Line 258
Last Updated: 20 June, 2023