rotateCameraWorld Method
Rotate the camera from its current location about an axis in world coordinates.
rotateCameraWorld(angle: Angle, axis: Vector3d, aboutPt?: Point3d): ViewStatus
Parameter | Type | Description |
---|---|---|
angle | Angle | The angle to rotate the camera. |
axis | Vector3d | The world-based axis (direction) about which to rotate the camera. |
aboutPt | Point3d | The point, in world coordinates, about which the camera is rotated. If aboutPt is undefined, the camera rotates in place (i.e. about the current eyePoint). |
Returns - ViewStatus
Status indicating whether the camera was successfully positioned. See values at ViewStatus for possible errors.
Defined in
- core/frontend/src/ViewState.ts Line 1939
Last Updated: 20 June, 2023