rotateCameraLocal Method
Rotate the camera from its current location about an axis relative to its current orientation.
rotateCameraLocal(angle: Angle, axis: Vector3d, aboutPt?: Point3d): ViewStatus
note Even though the axis is relative to the current camera orientation, the aboutPt is in world coordinates, \b not relative to the camera.
Parameter | Type | Description |
---|---|---|
angle | Angle | The angle to rotate the camera. |
axis | Vector3d | The axis about which to rotate the camera. The axis is a direction relative to the current camera orientation. |
aboutPt | Point3d | The point, in world coordinates, about which the camera is rotated. If aboutPt is undefined, the camera rotates in place (i.e. about the current eyePoint). |
Returns - ViewStatus
Status indicating whether the camera was successfully positioned. See values at ViewStatus for possible errors.
Defined in
- core/frontend/src/ViewState.ts Line 1927
Last Updated: 20 June, 2023