moveCameraGlobal Method
Move camera about the global ellipsoid. This rotates the camera position about the center of the global ellipsoid maintaining the current height.
moveCameraGlobal(fromPoint: Point3d, toPoint: Point3d): ViewStatus
Parameter | Type | Description |
---|---|---|
fromPoint | Point3d | Point to pan from. |
toPoint | Point3d |
Returns - ViewStatus
Status indicating whether the camera was successfully positioned. See values at ViewStatus for possible errors.
Defined in
- core/frontend/src/ViewState.ts Line 1955
Last Updated: 20 June, 2023