zoomToVolume Method
Zoom the view to a volume of space in world coordinates.
zoomToVolume(volume: Readonly<WritableLowAndHighXYZ> | Readonly<WritableLowAndHighXY>, options?: ViewChangeOptions & MarginOptions): void
Parameter | Type | Description |
---|---|---|
volume | Readonly<WritableLowAndHighXYZ> | Readonly<WritableLowAndHighXY> | The low and high corners, in world coordinates. |
options | ViewChangeOptions & MarginOptions | options that control how the view change works |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 2070
Last Updated: 20 June, 2023