isPointVisibleXY Method
Determine whether the supplied point is visible in the viewport rectangle.
isPointVisibleXY(point: Point3d, coordSys: CoordSystem = CoordSystem.World, borderPaddingFactor: number = 0.0): boolean
Parameter | Type | Description |
---|---|---|
point | Point3d | the point to test |
coordSys | CoordSystem | the coordinate system of the specified point |
borderPaddingFactor | number | optional border for testing with inset view rectangle. |
Returns - boolean
Defined in
- core/frontend/src/Viewport.ts Line 1651
Last Updated: 20 June, 2023