getSubCategoryAppearance Method
Query the symbology with which geometry belonging to a specific subcategory is rendered within this viewport. Every SubCategory defines a base symbology independent of any Viewport. If a SubCategoryOverride has been applied to the subcategory within the context of this Viewport, it will be applied to the subcategory's base symbology.
getSubCategoryAppearance(id: string): SubCategoryAppearance
see Viewport.overrideSubCategory
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory. |
Returns - SubCategoryAppearance
The symbology of the subcategory within this viewport, including any overrides.
Defined in
- core/frontend/src/Viewport.ts Line 674
Last Updated: 20 June, 2023