invalidateCachedDecorationsAllViews Method
Beta
Force each registered Viewport to regenerate all of its cached Decorations on the next frame. If the decorator parameter is specified, only the specified decorator will have its cached decorations invalidated for all viewports.
invalidateCachedDecorationsAllViews(decorator: ViewportDecorator): void
see Viewport.invalidateCachedDecorations to manually remove a decorator's cached decorations from a viewport, forcing them to be regenerated.
Parameter | Type | Description |
---|---|---|
decorator | ViewportDecorator |
Returns - void
Defined in
- core/frontend/src/ViewManager.ts Line 340
Last Updated: 20 June, 2023