connectViewports MethodProtected
Invoked from TwoWayViewportSync.connect to set up the initial synchronization between the two viewports.
target
should be modified to match source
.
The default implementation applies a clone of source
's ViewState to target
.
connectViewports(source: Viewport, target: Viewport): void
see TwoWayViewportSync.syncViewports to customize subsequent synchronization.
Parameter | Type | Description |
---|---|---|
source | Viewport | |
target | Viewport |
Returns - void
Defined in
- core/frontend/src/ViewportSync.ts Line 152
Last Updated: 20 June, 2023