TwoWayViewportFrustumSync Class
Forms a bidirectional connection between two Viewports such that the Frustums of each are synchronized with one another. For example, zooming out in one viewport will zoom out by the same distance in the other viewport. No other aspects of the viewports are synchronized - they may have entirely different display styles, category/model selectors, etc.
see TwoWayViewportSync to synchronize all aspects of the viewports.
see connectViewportFrusta to synchronize the frusta of more than two viewports.
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(): TwoWayViewportFrustumSync |
Inherited methods
Name | Inherited from | Description |
---|---|---|
connect(viewport1: Viewport, viewport2: Viewport): void | TwoWayViewportSync | Establish the connection between two Viewports. |
disconnect(): void | TwoWayViewportSync | Remove the connection between the two views. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_disconnect ProtectedReadonly | VoidFunction[] | TwoWayViewportSync |
Defined in
- core/frontend/src/ViewportSync.ts Line 193
Last Updated: 20 June, 2023