pickNearestVisibleGeometry Method
Find a point on geometry visible in this Viewport, within a radius of supplied pick point.
pickNearestVisibleGeometry(pickPoint: Point3d, radius?: number, allowNonLocatable: boolean = true, out?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
pickPoint | Point3d | Point to search about, in world coordinates |
radius | number | Radius, in pixels, of the circular area to search. |
allowNonLocatable | boolean | If true, include geometry with non-locatable flag set. |
out | Point3d | Optional Point3d to hold the result. If undefined, a new Point3d is returned. |
Returns - undefined | Point3d
The point, in world coordinates, on the element closest to pickPoint
, or undefined if no elements within radius
.
Defined in
- core/frontend/src/Viewport.ts Line 3096
Last Updated: 20 June, 2023