OffScreenViewportOptions Interface
Options supplied when creating an OffScreenViewport.
see OffScreenViewport.create.
Properties
Name | Type | Description | |
---|---|---|---|
lockAspectRatio | undefined | boolean | If true, the viewport's aspect ratio will remain fixed. | |
view | ViewState | The view to be drawn in the viewport. | |
viewRect | ViewRect | The dimensions of the viewport. |
Defined in
- core/frontend/src/Viewport.ts Line 3578
Last Updated: 20 June, 2023