ChangeFlags Class
Describes which aspects of a Viewport have changed. Each time Viewport.renderFrame is invoked, the aspects of the viewport that have changed since
the previous call to renderFrame
are computed and dispatched via the Viewport.onViewportChanged event.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
alwaysDrawn Accessor ReadOnly | boolean | The set of always-drawn elements has changed. | |
areFeatureOverridesDirty Accessor ReadOnly | boolean | Returns true if any aspects affecting FeatureSymbology.Overrides have changed. | |
displayStyle Accessor ReadOnly | boolean | The DisplayStyleState or its settings such as ViewFlags have changed. | |
featureOverrideProvider Accessor ReadOnly | boolean | The FeatureOverrideProvider has changed, or its internal state has changed such that its overrides must be recomputed. | |
hasChanges Accessor ReadOnly | boolean | Returns true if any aspect at all has changed. | |
neverDrawn Accessor ReadOnly | boolean | The set of never-drawn elements has changed. | |
viewedCategories Accessor ReadOnly | boolean | The set of displayed categories defined by the viewport's CategorySelectorState has changed. | |
viewedCategoriesPerModel Accessor ReadOnly | boolean | The PerModelCategoryVisibility.Overrides associated with the viewport have changed. | |
viewedModels Accessor ReadOnly | boolean | The set of models to be displayed in the viewport has changed. | |
viewState Accessor ReadOnly | boolean | changeView was used to replace the previous ViewState with a new one. |
Defined in
- core/frontend/src/ChangeFlags.ts Line 33
Last Updated: 20 June, 2023