isOriginInView MethodStatic
Given an origin point, returns whether the point falls within the view or not. If adjustOrigin is set to true, a point outside the view will be modified to fall within the appropriate range.
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean
Parameter | Type | Description |
---|---|---|
drawOrigin | Point3d | |
viewport | Viewport | |
adjustOrigin | boolean |
Returns - boolean
Defined in
- core/frontend/src/AuxCoordSys.ts Line 130
Last Updated: 20 June, 2023