ViewClipDecorationProvider Class
An implementation of ViewClipEventHandler that responds to new clips by presenting clip modification handles
Implements
Methods
Name | Description | |
---|---|---|
constructor(): ViewClipDecorationProvider | ||
clearOnDeselect(): boolean | Stop displaying clip geometry when clip is removed from the selection set. | |
hideDecoration(): void | ||
onClearClip(viewport: ScreenViewport): void | Called when the view clip is cleared from the view. | |
onModifyClip(viewport: ScreenViewport): void | Called by tools after modifying the view clip. | |
onNewClip(viewport: ScreenViewport): void | Called by tools that set or replace the existing view clip with a new clip. | |
onNewClipPlane(viewport: ScreenViewport): void | Called by tools that add a single plane to the view clip. | |
onRightClick(hit: HitDetail, ev: BeButtonEvent): boolean | Called when user right clicks on clip geometry or clip modify handle. | |
selectOnCreate(): boolean | Add newly created clip geometry to selection set and show modify controls. | |
showDecoration(vp: ScreenViewport): void | ||
toggleDecoration(vp: ScreenViewport): Promise<undefined | string> | ||
clear(): void Static | ||
create(): ViewClipDecorationProvider Static |
Properties
Name | Type | Description | |
---|---|---|---|
clearDecorationOnDeselect | boolean | ||
onActiveClipChanged Readonly | BeEvent<(viewport: Viewport, eventType: ClipEventType, provider: ViewClipDecorationProvider) => void> | Called when the active clip for a view is changed | |
onActiveClipRightClick Readonly | BeEvent<(hit: HitDetail, ev: BeButtonEvent, provider: ViewClipDecorationProvider) => void> | Called on a right click over the clip geometry or clip modify handle. | |
selectDecorationOnCreate | boolean |
Defined in
- core/frontend/src/tools/ClipViewTool.ts Line 1977
Last Updated: 20 June, 2023