changeToolSettingPropertyValue Method
Helper method for responding to a tool setting property value change by updating saved settings.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean
see InteractiveTool.applyToolSettingPropertyChange
see InteractiveTool.getToolSettingPropertyLocked to return the corresponding locked property, if any.
Parameter | Type | Description |
---|---|---|
syncItem | DialogPropertySyncItem |
Returns - boolean
Defined in
- core/frontend/src/tools/Tool.ts Line 783
Last Updated: 20 June, 2023