FuzzySearch<T> Class
Methods
Name | Description | |
---|---|---|
constructor<T>(): FuzzySearch<T> | ||
onGetMultiWordSearchOptions(): FuseOptions<T> | Override to provide non-standard FuseOptions for searches where the a multiple word pattern is used | |
onGetSingleWordSearchOptions(): FuseOptions<T> | Override to provide non-standard FuseOptions for searches where the a single word pattern is used | |
search(searchedObjects: T[], keys: undefined[], pattern: string): FuzzySearchResults<T> | Call to conduct a fuzzy search of searchedObjects, looking at the 'key' member of each such object |
Defined in
- core/frontend/src/FuzzySearch.ts Line 12
Last Updated: 20 June, 2023