EventController Class
An EventController maps user input events from a Viewport to the ToolAdmin so that tools can process them. Viewports are assigned an EventController when they are registered with ViewManager.addViewport and they are destroyed with ViewManager.dropViewport.
extensions
Methods
Name | Description | |
---|---|---|
constructor(vp: ScreenViewport): EventController | ||
destroy(): void |
Properties
Name | Type | Description | |
---|---|---|---|
vp | ScreenViewport |
Defined in
Last Updated: 20 June, 2023