TileTreeParams Interface
Parameters used to construct a TileTree.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
clipVolume | undefined | RenderClipVolume | Optional clip volume applied to all tiles in the tree. | |
contentRange | undefined | Range3d | Optional volume tightly encompassing the contents of this tile tree - used for more accurate culling. | |
expirationTime | undefined | BeDuration | Optionally specifies the amount of time before tiles belonging to this tile tree are considered eligible for disposal after disuse. | |
iModel | IModelConnection | The IModelConnection to which the tile tree belongs. | |
id | string | Uniquely identifies the tile tree in the context of the IModelConnection. | |
location | Transform | Transform from tile tree coordinates to iModel coordinates. | |
modelId | string | A 64-bit identifier for the tile tree, unique within the context of its IModelConnection. | |
priority | TileLoadPriority | Loose description of the "importance" of the tiles exposed by this tile tree, used for prioritizing requests for tile content. |
Defined in
Last Updated: 20 June, 2023