collectTileGeometry Method

Beta  

Populate TileGeometryCollector.polyfaces with geometry obtained from this tile tree's tiles satisfying the collector's criteria. The base implementation does nothing.

collectTileGeometry(_collector: TileGeometryCollector): void

see TileTreeReference.createGeometryTreeReference to attempt to create a TileTree that can collect geometry.

Parameter Type Description
_collector TileGeometryCollector  

Returns - void

Defined in

Last Updated: 20 June, 2023