TileBoundingBoxes Enumeration
Options for displaying tile bounding boxes for debugging purposes.
Bounding boxes are color-coded based on refinement strategy:
- Blue: A leaf tile (has no child tiles).
- Green: An ordinary tile (sub-divides into 4 or 8 child tiles).
- Red: A tile which refines to a single higher-resolution child occupying the same volume.
see Viewport.debugBoundingBoxes
extensions
Members
Name |
Value |
Description |
None |
0 |
Display no bounding boxes |
Volume |
1 |
Display boxes representing the tile's full volume. |
Content |
2 |
Display boxes representing the range of the tile's contents, which may be tighter than (but never larger than) the tile's full volume. |
Both |
3 |
Display both volume and content boxes. |
ChildVolumes |
4 |
Display boxes for direct children, where blue boxes indicate empty volumes. |
Sphere |
5 |
Display bounding sphere. |
SolidBox |
6 |
Display a transparent solid box representing the tile's full volume.
alpha To be replaced with a separate option that applies to any of the other TileBoundingBoxes modes. |
Defined in
Last Updated:
20 June, 2023