RealityDataSource Namespace
Beta
Utility functions for RealityDataSource
Function
Name | Description |
---|---|
RealityDataSource.createKeyFromUrl | Create a RealityDataSourceKey from a tilesetUrl. |
Defined in
RealityDataSource Interface
Beta
This interface provide methods used to access a reality data from a reality data provider
Methods
Name | Description | |
---|---|---|
getPublisherProductInfo(): Promise<undefined | > | Gets information to identify the product and engine that create this reality data | |
getRootDocument(iTwinId: undefined | string): Promise<any> | Gets a reality data root document json | |
getServiceUrl(iTwinId: undefined | string): Promise<undefined | string> | This method returns the URL to obtain the Reality Data properties. | |
getSpatialLocationAndExtents(): Promise<undefined | > | Gets spatial location and extents of this reality data source. | |
getTileContent(name: string): Promise<any> | Gets tile content | |
getTileContentType(url: string): "tile" | "tileset" | Given the URL of a tile's content, return the type of that content. | |
getTileJson(name: string): Promise<any> | Gets a tileset's app data json |
Properties
Name | Type | Description | |
---|---|---|---|
isContextShare Readonly | boolean | ||
key Readonly | RealityDataSourceKey | ||
maximumScreenSpaceError Readonly | undefined | number | If RealityDataSource.usesGeometricError is true , optionally specifies the maximum error, in pixels, to permit for a tile before requiring refinement of that tile. |
|
realityData Readonly | undefined | RealityData | Metatdata on the reality data source | |
realityDataId Readonly | undefined | string | ||
realityDataType Readonly | undefined | string | The reality data type (e.g.: "RealityMesh3DTiles", OPC, Terrain3DTiles, Cesium3DTiles, ... | |
usesGeometricError Readonly | undefined | boolean | If true, the geometricError property of the tiles will be used to compute screen-space error. |
Defined in
Last Updated: 20 June, 2023