ReadGltfGraphicsArgs Interface
Arguments supplied to readGltfGraphics to produce a RenderGraphic from a glTF asset.
Properties
Name | Type | Description | |
---|---|---|---|
baseUrl | string | URL | The base URL for any relative URIs in the glTF. | |
contentRange | undefined | Range3d | ||
gltf | Object | Uint8Array | A representation of the glTF data as one of: | |
hasChildren | undefined | boolean | ||
iModel | IModelConnection | The iModel with which the graphics will be associated - typically obtained from the Viewport into which they will be drawn. | |
pickableOptions | undefined | PickableGraphicOptions | Options for making the graphic pickable. | |
transform | undefined | Transform |
Defined in
- core/frontend/src/tile/GltfReader.ts Line 1665
Last Updated: 20 June, 2023