RealityMeshParamsBuilderOptions Interface
Beta
Options used to construct a RealityMeshParamsBuilder.
Properties
Name | Type | Description | |
---|---|---|---|
initialIndexCapacity | undefined | number | If defined, memory for this number of indices will be allocated up-front. | |
initialVertexCapacity | undefined | number | If defined, memory for this number of vertices will be allocated up-front. | |
positionRange | Range3d | A bounding box fully containing the positions of all vertices to be included in the mesh. | |
uvRange | undefined | Range2d | A range fully containing the texture coordinates of all vertices to be included in the mesh. | |
wantNormals | undefined | boolean | If true, RealityMeshParams.normals will be populated. |
Defined in
Last Updated: 20 June, 2023