PolylineParams Class
Describes a set of tesselated polylines. Each segment of each polyline is triangulated into a quad. Additional triangles may be inserted between segments to enable rounded corners.
Methods
Name | Description | |
---|---|---|
constructor(vertices: , polyline: , weight: number, linePixels: LinePixels, isPlanar: boolean, type: PolylineTypeFlags = PolylineTypeFlags.Normal): PolylineParams | Directly construct a PolylineParams. | |
create(args: PolylineArgs): undefined | PolylineParams Static | Construct from an PolylineArgs. |
Properties
Name | Type | Description | |
---|---|---|---|
isPlanar Readonly | boolean | ||
linePixels Readonly | LinePixels | ||
polyline Readonly | |||
type Readonly | PolylineTypeFlags | ||
vertices Readonly | |||
weight Readonly | number |
Defined in
Last Updated: 20 June, 2023