FlashSettings Class
Settings that control how geometry is "flashed" when hovered over in a Viewport. When the user hovers the mouse cursor over an element (or other piece of geometry, like a reality mesh), a Tool visually indicates that it can interact with that geometry by "flashing" it. Flashed geometry changes color in one of the following two ways:
- By mixing the viewport's hilite color as specified by Viewport.hilite with the geometry's own color; or
- By brightening the geometry's own color (for lit geometry only - i.e., meshes displayed in a view with lighting enabled). The flash effect starts out at an intensity of zero and increases linearly over the period of time specified by FlashSettings.duration until FlashSettings.maxIntensity is reached.
see Viewport.flashSettings to customize the flash behavior for a viewport.
see Viewport.hilite to customize the hilite color used by FlashMode.Hilite.
extensions
Methods
Name | Description | |
---|---|---|
constructor(options?: Mutable<Partial<FlashSettings>>): FlashSettings | Construct new flash settings. | |
clone(options?: Mutable<Partial<FlashSettings>>): FlashSettings | Create a copy of these settings identical except for properties explicitly specified by options . |
Properties
Name | Type | Description | |
---|---|---|---|
duration Readonly | BeDuration | The duration in seconds over which the flash effect increases from zero to FlashSettings.maxIntensity, in [0..10]. | |
litMode Readonly | FlashMode | Specifies how lit geometry (that is, meshes displayed in a view with lighting enabled) is flashed. | |
maxIntensity Readonly | number | The maximum intensity of the flash effect, after FlashSettings.duration seconds have elapsed, in [0..1]. |
Defined in
Last Updated: 20 June, 2023