unanimatedAppearance
Accessor
Establish a default appearance to apply to elements that are not animated by the view's RenderSchedule.Script.
unanimatedAppearance: undefined | FeatureAppearance
note If this is the only change made to EmphasizeElements, you must call Viewport.setFeatureOverrideProviderChanged for the change to take immediate effect.
see EmphasizeElements.createDefaultAppearance to create an appearance suitable for de-emphasizing the non-animated elements.
Returns - undefined | FeatureAppearance
Setter
Establish a default appearance to apply to elements that are not animated by the view's RenderSchedule.Script.
unanimatedAppearance(appearance: undefined | FeatureAppearance): void
note If this is the only change made to EmphasizeElements, you must call Viewport.setFeatureOverrideProviderChanged for the change to take immediate effect.
see EmphasizeElements.createDefaultAppearance to create an appearance suitable for de-emphasizing the non-animated elements.
Parameter | Type | Description |
---|---|---|
appearance | undefined | FeatureAppearance |
Returns - void
Defined in
Last Updated: 20 June, 2023