addDecoration Method
Adds a graphic to the set of Decorations to be drawn in this context's ScreenViewport.
addDecoration(type: GraphicType, decoration: RenderGraphic): void
note The type must match the type with which the RenderGraphic's GraphicBuilder was constructed.
see DecorateContext.addDecorationFromBuilder for a more convenient API.
Parameter | Type | Description |
---|---|---|
type | GraphicType | |
decoration | RenderGraphic | The decoration graphic to add. |
Returns - void
Defined in
- core/frontend/src/ViewContext.ts Line 228
Last Updated: 20 June, 2023