pullChanges Method
Pull (and potentially merge if there are local changes) up to a specified changeset from iModelHub into this briefcase
pullChanges(toIndex?: number, options?: PullChangesOptions): Promise<void>
see BriefcaseTxns.onChangesPulled for the event dispatched after changes are pulled.
Parameter | Type | Description |
---|---|---|
toIndex | number | The changeset index to pull changes to. If undefined , pull all changes. |
options | PullChangesOptions | Options for pulling changes. |
Returns - Promise<void>
Defined in
Last Updated: 20 June, 2023